USB Ports are Problematic

View previous topic View next topic Go down

USB Ports are Problematic

Post by Mystagan on Sat Aug 04, 2012 2:28 am

I have a Toshiba Satellite A205 and recently, my USB's only work on the top left USB port; my camera, the top right; and extra, the bottom left; and iTouch, bottom right. These are not interchangeable! Any advice?

Mystagan
Novice
Novice

Status :
Online
Offline

Posts : 31
Joined : 2012-07-12
OS : Windows 7

View user profile

Back to top Go down

Re: USB Ports are Problematic

Post by T0k3n on Sat Sep 01, 2012 1:29 pm

Most likely a faulty port.
Have you tried different peripherals connected to the port?
Inspect the contacts inside the port to see if damaged.

T0k3n
Intermediate
Intermediate

Status :
Online
Offline

Posts : 50
Joined : 2011-10-25
Gender : Male
OS : Windows 7

View user profile

Back to top Go down

Re: USB Ports are Problematic

Post by Mystagan on Mon Sep 03, 2012 4:35 am

The individual USB ports are working but only for different appliances.

Mystagan
Novice
Novice

Status :
Online
Offline

Posts : 31
Joined : 2012-07-12
OS : Windows 7

View user profile

Back to top Go down

Re: USB Ports are Problematic

Post by T0k3n on Mon Sep 03, 2012 11:26 pm

Try uninstalling the USB hubs from Device Manager and restart Windows.

Once Windows restarts the hubs will be reinstalled.

T0k3n
Intermediate
Intermediate

Status :
Online
Offline

Posts : 50
Joined : 2011-10-25
Gender : Male
OS : Windows 7

View user profile

Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum