WD My Book on Vista 64-bit

View previous topic View next topic Go down

Solved WD My Book on Vista 64-bit

Post by SirIcare on Mon 08 Jun 2009, 5:38 am

I've just bought a new computer that i mounted myself. BRand new slick quad-core with 2 GB of RAM. I've chosen to install Vista 64-bit to benefit from Windows' recognition of anything greater than dual cores.
But i've ran into a little problem when plugging back my 1 TB from WesterDigital. It worked fine on Vista 32-bit... but now it isn't recognized by newer Vista 64-bit. To verify that the drive was still ok, i tried replugging it to the Vista 32-bit... but nnow, nothing works nowhere! The drive isn't recognized by either OS: 32-bit or 64-bit.

What did I do wrong? Am i missing a driver? I've looked on the web and looks like this will not work... please help me!


Newbie Surfer
Newbie Surfer

Posts : 5
Joined : 2009-05-19
Operating System : XP

View user profile

Back to top Go down

Solved Re: WD My Book on Vista 64-bit

Post by Doctor Inferno on Tue 09 Jun 2009, 9:05 pm


I'm guessing the firmware in your hard drive is corrupted, probably because it wasn't removed properly or correctly. Can you try and plug it to another USB port and see if the problem persists? Also, make sure it's plugged directly to the back of the computer.

Please be a GeekPolice fan on Facebook!

Have we helped you? Help us! | Doctor by day, ninja by night.

Doctor Inferno
The GeekPolice

The GeekPolice

Posts : 12017
Joined : 2007-12-27
Operating System : Windows 7 Home Premium and Ultimate X64

View user profile http://twitter.com/GeekPolice

Back to top Go down

View previous topic View next topic Back to top

Permissions in this forum:
You cannot reply to topics in this forum